Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8712

Add deprecation warning for puppet <subcommand> --configprint

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.3
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      The `--configprint` flag is now deprecated. When running `puppet <subcommand> --configprint` with the debug or verbose flag, users are given a deprecation warning, and are directed to instead use `puppet config <subcommand>`
    • QA Risk Assessment:
      Needs Assessment

      Description

      We added a deprecation warning when running puppet master, but if you run puppet master --configprint it exits before the deprecation warning is emitted. Since we're removing the master application in 6.0, we need to emit a deprecation warning in 5.y for the configprint case, and say to use puppet config print [setting] --section master instead. /cc Nick Walker

        Attachments

          Activity

            People

            Assignee:
            jorie Jorie Tappa
            Reporter:
            josh Josh Cooper
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support