Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8762

deprecate `puppet module build` in favor of `pdk build`

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.y
    • Fix Version/s: PUP 5.5.3
    • Component/s: PMT
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      Hide
      The `puppet module build` command is deprecated and will be removed in a future release. To build modules to upload it to the forge, use the [Puppet Development Kit](https://puppet.com/download-puppet-development-kit) instead.
      Show
      The `puppet module build` command is deprecated and will be removed in a future release. To build modules to upload it to the forge, use the [Puppet Development Kit]( https://puppet.com/download-puppet-development-kit ) instead.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Since pdk build has been released with PDK 1.4.1 (PDK-748), we can deprecate puppet module build in the 5.y series, to be removed in puppet 6.

      cc Bryan Jen Josh Cooper

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  david.schmitt David Schmitt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: