Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8767

--config_version option to `puppet apply` leads to ruby-specific lastrun YAML

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: PUP 5.5.1
    • Fix Version/s: PUP 5.5.3
    • Component/s: None
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      When config_version refers to an external program, the last run summary no longer includes the puppet-specific class name in the YAML output, to ensure interoperability with other programs.
    • QA Risk Assessment:
      Needs Assessment

      Description

      If you run puppet apply --config_version='echo foo' -e 'notify { "bar": }' then the last run summary YAML ends up looking like this

      ---
      version:
       config: !ruby/string:Puppet::Util::Execution::ProcessOutput "foo"
      [...]
      

      Having the explicit typing makes it difficult to parse with general YAML tools.

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            rhowe-gds Russell Howe
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support