Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8997

Deprecate Faces related to CA and certificate handling

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PUP 5.5.6
    • Docs
    • Hide

      All certificate and CA-related faces are issue deprecation warnings when used.

      Show
      All certificate and CA-related faces are issue deprecation warnings when used.
    • Froyo
    • Deprecation
    • Hide
      We are deprecating all puppet subcommands that perform actions on the CA. This includes cert, ca, certificate, certificate_revocation_list, and certificate_request. Their functionality will be replaced in Puppet 6 by a new CA CLI under puppetserver and a new client-side subcommand for SSL client tasks.
      Show
      We are deprecating all puppet subcommands that perform actions on the CA. This includes cert, ca, certificate, certificate_revocation_list, and certificate_request. Their functionality will be replaced in Puppet 6 by a new CA CLI under puppetserver and a new client-side subcommand for SSL client tasks.
    • Needs Assessment

    Description

      In order to streamline the experience of interacting with Puppet's SSL infrastructure, we are planning to replace the confusing series of puppet faces with two simple CLI tools, one for the agent (client) side, and one for puppetserver (CA). This ticket is to deprecate them before removing them.

      Attachments

        Activity

          People

            maggie Maggie Dreyer
            maggie Maggie Dreyer
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support