Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9020

Give a deprecation error when top level constructs are found in modules

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.7
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Give a deprecation warning during puppet code validation when toplevel constructs are found in autoloaded module files.

      Show
      Give a deprecation warning during puppet code validation when toplevel constructs are found in autoloaded module files.
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      A deprecation warning will be given during puppet code validation when toplevel constructs that are not defines are found in autoloaded module files.
    • QA Risk Assessment:
      Needs Assessment

      Description

      This is the deprecation warning for this error:

      No toplevel constructs (resources, variable assignments, include statements, import statements, etc) are allowed in autoloaded modules.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kris.bosland Kris Bosland
              Reporter:
              kris.bosland Kris Bosland
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support