Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9027

Deprecate CA-related settings in puppet.conf

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.6
    • Component/s: Docs
    • Labels:
    • Template:
    • Acceptance Criteria:
      • CA related settings in puppet issue deprecation warnings when set
    • Team:
      Froyo
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      We are deprecating the Puppet settings relating to CA file locations, since these will be replaced by similar settings in Puppet Server's configs in Puppet 6.
    • QA Risk Assessment:
      Needs Assessment

      Description

      In SERVER-2222 for Puppet 6 we are defining a bunch of CA related settings in puppetserver's config that will be respected instead of the ones in puppet.conf. We need to deprecate the puppet.conf versions of these settings in Puppet 5.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              maggie Maggie Dreyer
              Reporter:
              maggie Maggie Dreyer
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support