Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9044

Update puppet portage package provider for new output generated by qatom

    Details

    • Template:
    • Team:
      Platform OS
    • Sprint:
      Platform OS Kanban
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Update the Portage package provider for changes to Gentoo package management
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: puppet-agent-5.5.4
      Puppet Server Version: 5.3.4
      OS Name/Version: Gentoo

      qatom output used to look like:

      1. qatom app-admin/puppet
        app-admin puppet (null)

      ...but now looks like...

      1. qatom app-admin/puppet
        app-admin puppet <unset>

      in app-portage/portage-utils-0.72 and above.

      Desired Behavior: the qatom output to be parsed correctly

      Actual Behavior:

      Error: Could not update: Execution of '/usr/bin/emerge -update app-admin/puppet<unset>' returned 1: !!! 'app-admin/puppet-<unset>' is not a valid package atom.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                prometheanfire Matthew Thode
                Reporter:
                prometheanfire Matthew Thode
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: