Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9091

Change deprecation warning for illegal top level constructs to an error

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      The deprecation for illegal top level constructs is now an error.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Illegal top level constructs have been given a deprecation warning in Puppet 5.5.x with PUP-9020, now in Puppet 6.0.0 they should be reported as an error.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  kris.bosland Kris Bosland
                  Reporter:
                  kris.bosland Kris Bosland
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: