Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9116

Remove CA related deprecation warnings

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.5.6
    • Fix Version/s: PUP 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Server
    • Method Found:
      Needs Assessment
    • Release Notes:
      Known Issue
    • Release Notes Summary:
      Hide
      We are no longer deprecating CA-related settings (see PUP-9027 for list of settings that were deprecated and are being undeprecated). We are no longer removing these settings in Puppet 6.
      Show
      We are no longer deprecating CA-related settings (see PUP-9027 for list of settings that were deprecated and are being undeprecated). We are no longer removing these settings in Puppet 6.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet 5.5.6 will emit deprecation warnings for ca related settings even if the setting is never set on the CLI or in settings:

      $ bx puppet agent -t
      Warning: Accessing 'ca' as a setting is deprecated.
         (location: /Users/josh/work/puppet/lib/puppet/settings.rb:1165:in `issue_deprecation_warning')
      Exiting; no certificate found and waitforcert is disabled
      

      We should remove these warning from the settings entirely, as they will still be available in Puppet 6.

      See PUP-9027

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                justin Justin Stoller
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support