Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9158

Remove deprecations from CA related settings in Puppet 5

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.5.6
    • Fix Version/s: PUP 5.5.7
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      • CA-related settings no longer issue deprecation warnings
    • Team:
      Froyo
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      We have removed the deprecation warnings for most of the CA settings that were shipped prematurely in 5.5.6. All the CA settings besides `capass` and `caprivatedir` will still continue to function in Puppet 6.
    • QA Risk Assessment:
      Needs Assessment

      Description

      We did this in 6, still need to do it in 5. See PUP-9116.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              maggie Maggie Dreyer
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support