Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9266

Only show deprecation of CA setting when it is set in the config file

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PUP 5.5.8
    • None
    • None
    • Froyo
    • Customer Feedback
    • Not Needed
    • Needs Assessment

    Description

      When we fixed PUP-9158, we missed the :ca setting. Since it was actually removed in Puppet 6, we should keep the deprecation warning, but it should only be issued from a hook called when the setting is set in the file, not any time it is used in code.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              maggie Maggie Dreyer
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support