Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9308

stack level too deep (SystemStackError)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Incomplete
    • PUP 5.5.6
    • None
    • Compiler
    • None
    • Needs Assessment
    • Needs Assessment

    Description

      Puppet Version:5.5.x
      Puppet Server Version:5.5.6
      OS Name/Version: puppet agent: windows server 2012r2 /puppet server: centos 7

      when i running puppet apply pp file and pp size more than 200k, i got error:

      C:/Program Files/Puppet Labs/Puppet/sys/ruby/lib/ruby/vendor_ruby/puppet/parser/compiler.rb:33:in `new': stack level too deep (SystemStackError)

      same pp i was running on puppet 3.7, it's work well. 

       

      Attachments

        Activity

          People

            kenma ken ma
            kenma ken ma
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support