Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9356

`puppet device` does not load local plugins for --apply --facts and --resource

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: PUP 5.5.8, PUP 6.0.4
    • Fix Version/s: PUP 5.5.10, PUP 6.0.5, PUP 6.1.0
    • Component/s: None
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Network Automation
    • Method Found:
      Automated Test
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      The changes in PUP-8766 (https://github.com/puppetlabs/puppet/pull/7242) removed plugin loading from a local environment for `puppet device`, even in the cases where local content is supposed to be used.

      The issue was detected in Resource API acceptance testing yesterday after the merge-up from 5.5.x to 6.0.x. The fix should be trivially mergeable to 6.0.x and beyond.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  david.schmitt David Schmitt
                  Reporter:
                  david.schmitt David Schmitt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support