Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9555

Update FFI dependency for Ruby 2.6 compatibility

    Details

    • Type: Improvement
    • Status: Ready for Merge
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: PUP 6.3.0
    • Fix Version/s: None
    • Component/s: Windows
    • Labels:
    • Template:
    • Team:
      Coremunity
    • Story Points:
      1
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet cannot be `bundle install`'d on Windows due to too strict a version requirement on FFI (of ~> 1.9.25). FFI did not add Window gems for Ruby 2.6 support until FFI 1.10.0.

       

      Change the requirement accordingly.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  ethan Ethan Brown
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated: