Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9649

Backport certname mismatch to 5.5.x and 6.0.x (PUP-8213)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.16, PUP 6.0.10
    • Component/s: None
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      When running with ruby 2.4 or 2.5, ruby will raise a certname mismatch error before we have a chance to handle it, and print a meaningful message.

      This is a backport of the changes made in 6.4.x in PUP-8213

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  josh Josh Cooper
                  Reporter:
                  josh Josh Cooper
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support