Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Types and Providers
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 4.7.0
      Puppet Server Version:
      OS Name/Version: Ubuntu trusty

      Installed ruby 2.6 and trying to install ruby gems. gem provider always executes with flag --no-rdoc which is not supported in latest ruby gem. 

       

      [23.253.241.250] out: Debug: Executing '/usr/bin/gem install -v 6.4.2 --no-rdoc --no-ri puppet'
      [23.253.241.250] out: Error: Could not update: Execution of '/usr/bin/gem install -v 6.4.2 --no-rdoc --no-ri puppet' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
      [23.253.241.250] out: invalid option: --no-rdoc

      Desired Behavior:

      Gem should be installed without throwing invalid option error

      Actual Behavior:

       

      Throws the following error:

      [23.253.241.250] out: Debug: Executing '/usr/bin/gem install -v 6.4.2 --no-rdoc --no-ri puppet'
      [23.253.241.250] out: Error: Could not update: Execution of '/usr/bin/gem install -v 6.4.2 --no-rdoc --no-ri puppet' returned 1: ERROR: While executing gem ... (OptionParser::InvalidOption)
      [23.253.241.250] out: invalid option: --no-rdoc

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  iamvivek Vivek S
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: