Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9752

Systemd should be default service provider for Debian buster

    Details

    • Template:
    • Agent OS:
      Other
    • Acceptance Criteria:
      Hide

      systemd provider is defaultfor Debian 10 at least

      Show
      systemd provider is defaultfor Debian 10 at least
    • Team:
      Night's Watch
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      Puppet will select systemd as the default service provider on Debian 10 (buster).
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: (all released agent versions)
      Puppet Server Version:
      OS Name/Version: Debian 10

      The systemd provider is not a default for Debian 10 (buster) as released.  Thus services that only have systemd .service files and not init scripts won't be managed properly.

      Desired Behavior:

      Systemd should be the default for 10 (buster's release number) and probably also the forthcoming bullseye/sid.

      Actual Behavior:

      Running a puppetlabs-provided puppet-agent package on current buster (currently unsupported, I understand) results in services not being managed correctly.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  mjackson Martin Jackson
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: