Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.0.0
    • Component/s: Compiler
    • Labels:
      None

      Description

      The Ruby DSL has been deprecated since several 3x versions back and should be removed in 4.0.

      The future parser/evaluator does not support it at all.
      There are places in the logic where it is checked if the code of an AST is "ruby_code" and it takes a different path. This should be removed. The 3x AST still needs to be intact in 4.0.0 since not all expressions are evaluated by the new evaluator - but the ruby support should be removed.

      The Ruby DSL implementation can then be deleted from the codebase together with its tests.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                henrik.lindberg Henrik Lindberg
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support