Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-9915

Debian: avoid updating systemd defaults for every release

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 6.4.4, PUP 6.8.0
    • Component/s: Types and Providers
    • Labels:
      None
    • Environment:

      OS: Debian 10, any future version

    • Template:
    • Acceptance Criteria:
      Hide

      systemd is the default on ex., Debian 12

      Show
      systemd is the default on ex., Debian 12
    • Team:
      Night's Watch
    • Sprint:
      NW - 2019-08-07
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      systemd is the default init system for Debian since version 8. This enhancement makes Puppet default all future Debian versions to systemd.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: (all released agent versions)
      Puppet Server Version:
      OS Name/Version: Debian 10

       

      The systemd provider has a hard-coded list of Debian releases that use systemd. For the foreseeable future this should include all new releases. Right now the hard-coded list means the file needs updating for every release.

      Desired Behavior:

      systemd should be default-available on future releases.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                zeha Christian Hofstaedtler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support