Uploaded image for project: 'Razor'
  1. Razor
  2. RAZOR-132

Razor Fails to Create Repository if the Repository Name Contains Unicode Characters

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: RAZOR 0.14.0
    • Fix Version/s: RAZOR 0.15.0
    • Component/s: QA, Server
    • Labels:
    • Environment:

      PE Version: 3.2.0-rc0-1206-gd8d46cc
      Razor Version: 0.14
      Master: 2GB RAM - CentOS 6.4 x64
      Razor Server: 2GB RAM - CentOS 6.4 x64
      Node: 1GB RAM - CentOS 6.4 x64

    • Template:
    • Epic Link:
    • Story Points:
      3
    • Sprint:
      May 7

      Description

      Description

      If a user attempts to create a repo that has a name that contains Unicode characters, Razor will fail to create the repo.

      Inspection of the Razor repo directory ("/opt/puppet/var/razor/repo") reveals that no directory exists for the repo.

      Attachments

      • Razor logs

      Repro Steps

      1. Install and configure a Razor server.
      2. Install the Razor client on the Razor server.
      3. Create a PE broker.
      4. Execute the following command:

        razor create-repo --name 죾쒃쌼싁씜봜ㅛ짘홒녿 --iso-url <VALID_URL>

      Expect

      Razor should create a repository.

      Actual

      Razor never creates the repo directory, but does download the ISO from the URL to the "/tmp" directory.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              phong Phong Ly
              Reporter:
              ryan.gard Ryan Gard
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support