Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1308

Puppet Agent & Core don't agree with ruby/puppet submodule

    XMLWordPrintable

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Sub-team:
    • Story Points:
      3
    • Sprint:
      Server Emerald 2016-05-04

      Description

      The configured puppet-agent version we are pinned to in puppetserver(master) does not agree with the ruby/puppet submodule. The submodule is ahead. A modified test in the submodule (build_should_not_allow_symlinks.rb) fails because the expected puppet core code isn't installed on the system under test.

      The expected fix here is to modify the puppet-agent pin in acceptance/lib/helper.rb to a newer puppet agent build when a suitable build becomes available.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              erik Erik Dasher
              Reporter:
              erik Erik Dasher
              QA Contact:
              Erik Dasher
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support