Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1371

documentation improvement -- Version compatibillity matrix and wording upgrade

    Details

    • Type: New Feature
    • Status: Needs Information
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DOCS
    • Labels:
      None
    • Template:
    • CS Priority:
      Reviewed

      Description

      Documentation improvement

      _This report refers to https://github.com/puppetlabs/puppetserver#installing-puppet-server_

      The following paragraph is unclear:
      All versions of Puppet Server depend on at least Puppet 3.7.3, and since version 2.3 it depends on Puppet Agent 1.4.0 or newer, which installs Puppet 4.4 and compatible versions of its related tools and dependencies on the server. Puppet agents running older versions of Puppet Agent can connect to Puppet Server 2.3; this requirement applies to the Puppet Agent running on the Puppet Server node only.

      Compatibility Matrix

      It would be a great documentation enhancement for both the open source project and the puppet.com website if we could get a simple compatibility matrix indicating which versions of puppet agent connect to the different major versions of puppet-server and vice versa

      Why this is needed

      This ticket was prompted by feedback from a customer. He had read the highlighted paragraph as meaning that only the Puppet Agent on the master needs to be updated which is indeed one interpretation of the sentence. Because of this, he was getting errors when trying to connect puppet agent 3.2 to Puppet Server.

      Another Question he had was which versions of Puppet can he connect his agent to, eg can a puppet 4.5 agent connect to an old puppet 3.2 master.

      It would be great if we could have simple documentation and product compatibility matrices to help our users make this call. At present, its not obvious which versions of agent and master are compatible with each other unless I'm missing something. This leads me to recommend building test infrastructure just to test Puppet compatibility between versions which isn't an ideal situation.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                geoff.williams Geoff Williams
              • Votes:
                2 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Zendesk Support