Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1585

Allow JRuby compat-version to be configurable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: SERVER 2.7.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Enterprise in the Cloud
    • Story Points:
      2
    • Sprint:
      WC 2016-10-19, WC 2016-11-02
    • Release Notes:
      New Feature
    • Release Notes Summary:
      Allow JRuby compat-version to be configured via puppetserver.conf

      Description

      In Puppet Server and the jruby-utils library it uses, JRuby 1.7 has been hardcoded to work in "1.9" MRI Ruby compatibility mode. JRuby 1.7.x supports the ability to run in MRI Ruby emulation version 1.8, 1.9, or 2.0, though.

      Eventually, we would like to be able to upgrade Puppet Server to use JRuby 9000, which supports MRI Ruby 2.3. As we still have some blockers in JRuby that are preventing us from being able to do this migration and are seeing an increasing number of newer gems that require 2.0 or greater MRI Ruby version support – see SERVER-1544 – it seems worthwhile to consider making the "compat mode" version externally configurable. This would allow users to at least have an option to try to use MRI Ruby 2.0 features in Puppet Server until it is viable to switch to using JRuby 9000 instead.

      This ticket would involve work both in Puppet Server and in the JRuby Utils library.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jeremy.barlow Jeremy Barlow
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support