Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1670

Puppet Server 2.6 to 2.7 dependency change

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: SERVER 2.7.1
    • Fix Version/s: SERVER 2.7.2
    • Component/s: Puppet Server
    • Labels:
    • Environment:

      RHEL 6 x86_64, Puppet Server 2.6.0 upgrading to Puppet Server 2.7.1

    • Template:
    • Team:
      Next Generation
    • Story Points:
      1
    • Sprint:
      NG 2016-12-14
    • QA Risk Assessment:
      Needs Assessment

      Description

      Why does puppetserver now depend on /usr/bin/ruby? I was ecstatic when upgrading Puppet from 3.x to 4.x it no longer depended on the system's ruby. Shouldn't whatever requires ruby use the puppet-agent provided ruby instance?

      This is blocking my upgrade to 2.7.x as we no longer provide RHEL's base ruby packages. A innocent looking, moderate impact change of this scope should be held off to a major release.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                justin Justin Stoller
                Reporter:
                ruckc Curtis Ruck
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: