Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.0.0
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
    • Epic Link:
    • Team:
      Systems Engineering
    • Sub-team:
    • Story Points:
      3
    • Sprint:
      Server 2017-05-03
    • Release Notes:
      New Feature
    • Release Notes Summary:
      Hide
      Puppet Server is now using a newer version of the Jetty web server components, 9.4.4. This in turn requires that Puppet Server be built for use on Java 8 rather than Java 7. See SERVER-1738 for packaging changes related to Java 8.
      Show
      Puppet Server is now using a newer version of the Jetty web server components, 9.4.4. This in turn requires that Puppet Server be built for use on Java 8 rather than Java 7. See SERVER-1738 for packaging changes related to Java 8.
    • QA Risk Assessment:
      Needs Assessment

      Description

      This ticket builds on the work being done to support Jetty 9.4.x in trapperkeeper-webserver-jetty9, integrating the new tk-jetty9 into Puppet Server. As part of this ticket, we'll need to upgrade Puppet Server to be built for JDK 8. We may need to wait on this until supporting work in ezbake is done in RE-8191. We should also do some work to validate perf with the new tk-jetty9 although we may want to do that as a follow-up linked ticket for which we do a gatling A/B run.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  adrien Adrien Thebo
                  Reporter:
                  jeremy.barlow Jeremy Barlow
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: