Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1750

Vendor JRuby compatible msgpack gem

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.y
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
    • Team:
      Froyo
    • QA Risk Assessment:
      Needs Assessment

      Description

      In order to facilitate PUP-5908 we need to vendor the msgpack gem in puppetserver. Note a similar change is being made for the agent in PA-706.

      This will also make it possible to opt-into msgpack for agent/master communication.

      Note msgpack has native extensions. Also puppetserver will need to prefer the JRuby version of the gem as opposed to the one packaged into puppet-agent.

      /cc Henrik Lindberg, Jeremy Barlow, Geoff Nichols

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              josh Josh Cooper
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:

                  Zendesk Support