Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1782

Unable to build ezbake packages for SLES 12 since no java-1.8.0-openjdk-headless

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.0.0
    • Component/s: None
    • Labels:
      None
    • CI Pipeline/s:
      platform puppetserver
    • Epic Link:
    • Team:
      Systems Engineering
    • Sub-team:
    • Story Points:
      3
    • Sprint:
      Server 2017-05-03
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      After upgrading Puppet Server's master branch to ezbake version 1.2.0, we're unable to build packages correctly for SLES12. See this build failure. In particular, this appears to be due to the following error message:

      Error: No Package found for java-1.8.0-openjdk-headless
      

        Attachments

          Activity

            People

            • Assignee:
              adrien Adrien Thebo
              Reporter:
              jeremy.barlow Jeremy Barlow
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support