Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1787

Fix Puppet 3 Compatibility tests error installing puppet 3.8 on EL with Beaker 3.12

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Systems Engineering
    • Sub-team:
    • Story Points:
      1
    • Sprint:
      Server 2017-06-28
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      The Puppet 3 compatibility tests fail to install Puppet 3.8 on EL with Beaker 3.12+. This is due to the change in https://github.com/puppetlabs/beaker/commit/688a1c8b4042723fb578f2ded19e63c8e0c32ed4#diff-27026e05f9aa40b65dcfab171a40e73c.

      In the Puppet 3 compat tests we set type to aio. However, the agent we run is technically not aio - it needs to install Puppet 3.8. So we need the non PC1 url. We need to figure out how to set the agent/modify the agent so it has type foss or nil.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                adrien Adrien Thebo
                Reporter:
                ruth Ruth Linehan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: