Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-1920

grafanadash module no longer works

    XMLWordPrintable

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.1.0
    • Component/s: None
    • Labels:
      None
    • CI Pipeline/s:
      pe-puppet-server-extensions, platform puppetserver
    • Team:
      Platform Core
    • Story Points:
      3
    • Sprint:
      Platform Core 2017-08-08, Platform Core 2017-08-22
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action

      Description

      Our pipelines for both puppetserver and pe-puppet-server-extensions install the cprice404-grafanadash module to configure graphite and grafana and use them to test our graphite integration/operability.

      EPEL packages that these depend on have disappeared (Rob Braden can't find them either, I don't think this is just me). No one seems to interested in them and frankly this module is in the namespace of someone who no longer works here and depends on modules that are deprecated and/or over three years old at this point.

      To fix this situation we should:

      • pull this testing module into the puppetlabs namespace
      • update it's dependencies to a modern modules/versions
      • retarget its desired platform from CentOS 6 to 7 so we can be on a more modern OS
      • release this new module to the forge
      • update our tests to use it

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            justin Justin Stoller
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support