Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2003

Pin (and unpin when fixed) postgresql module in acceptance tests

    XMLWordPrintable

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 5.1.5
    • Component/s: None
    • Labels:
      None
    • CI Pipeline/s:
      platform puppetserver
    • Team:
      Platform Core
    • Sprint:
      Platform Core KANBAN
    • QA Risk Assessment:
      No Action

      Description

      The 5.2.0 release of the postgresql module included a minor ordering regression. Unfortunately, the puppetdb module was affected by this. Consequently, we pinned the postgresql module to 5.1 prior to installing the puppetdb module in our acceptance tests. here for 5.1.x+ and here for 2.x.

      With the release of postgresql 5.2.1 this is supposed to be fixed. We should attempt to unpin, test that it now works, and update our tests.

      Original failing job link: https://jenkins-master-prod-1.delivery.puppetlabs.net/job/platform_puppetserver_integration-system_no-conditional_smoke-2.x/17/

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              melissa Melissa Stone
              Reporter:
              maggie Maggie Dreyer
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support