Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2095

Bump default jruby from 1.7.27 to 9k

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Froyo
    • Sub-team:
    • Release Notes:
      New Feature
    • Release Notes Summary:
      Puppet Server 6.0 now uses JRuby 9k. This implements version 2.3 of the ruby language.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Hi,
      Puppetserver 5.1.4 ships jruby 1.7.27 as default, jruby 9k is optional. The jruby docs are a bit tricky, but if I understand https://github.com/jruby/jruby/issues/4112 correctly, jruby 1.7.27 is EOL. If that is true, the default version in puppetserver should be bumped to a supported version.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              patrick Patrick Carlisle
              Reporter:
              bastelfreak Tim Meusel
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support