Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2132

Update semantic_puppet gem dependency

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide
      • semantic_puppet should be at least 1.0.x in the gem-list
      • it should be possible to run puppet-agent 6.0 and the latest puppetserver 5.3.x package on the same host, as will happen in PE when using puppet apply to update puppetserver from 5.3 to 6.0.
      Show
      semantic_puppet should be at least 1.0.x in the gem-list it should be possible to run puppet-agent 6.0 and the latest puppetserver 5.3.x package on the same host, as will happen in PE when using puppet apply to update puppetserver from 5.3 to 6.0.
    • Team:
      Coremunity
    • Sub-team:
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      New Feature
    • Release Notes Summary:
      The version of semantic_puppet has been updated in Puppet Server to ensure backwards compatibility in preparation for future major releases of Puppet Platform.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppetserver depends on an old semantic_puppet gem. We should delete semantic_puppet from https://github.com/puppetlabs/puppetserver/blob/a4f2b5445c62311f23fcdbf8f836b150cd29cabe/resources/ext/build-scripts/gem-list.txt so that it no longer bundles semantic_puppet.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                jorie Jorie Tappa
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: