Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2161

Document issues with third party gems when upgrading 9k

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: SERVER 5.3.0
    • Fix Version/s: SERVER 5.3.1
    • Component/s: DOCS, Puppet Server
    • Labels:
      None
    • Release Notes:
      Known Issue
    • Release Notes Summary:
      See the ticket description, which will be updated with known issues and workarounds.
    • QA Risk Assessment:
      Needs Assessment

      Description

      This is a ticket to track issues that we or the community run into with gem dependencies when switching from JRuby 1.7 to JRuby 9k. Please edit the description to keep it current with the known issues.

      Problem: Autosign 0.1.2/Yard 0.8.x
      Yard's rubygem integration is incompatible with the rubygems version we ship with 9k. It seems to cause a warning printed during puppetserver gem list (called during puppet runs applying updates via the puppetserver_gem provider). In our case this is caused by using autosign 0.1.2. Upgrading to autosign 0.1.3 bumps the yard requirement to a version compatible with the rubygems we ship in 9k based puppetserver.

      Solution:
      Upgrade yard to a 0.9.x version and look at bumping any server side gems that require yard 0.8.x. The autosign gem specifically should be at >= 0.1.3.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                justin Justin Stoller
                Reporter:
                justin Justin Stoller
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: