Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2236

puppetserver doesnt load report handlers from /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/reports/

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: SERVER 5.3.3
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Server
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      I tried to deploy a custom report handler today in /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/reports/, but also the default handlers are not loaded:

      puppetserver.log:

      Puppet No report named 'log'
       
      Puppet No report named 'custom'
      
      

       

      If I put the handler in a module under lib/puppet/reports/custom.rb it is loaded correctly and works.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  simon.hoenscheid Simon Hoenscheid
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: