Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2300

Puppet server 5.3 status endpoint doesn't work

    Details

    • Type: Bug
    • Status: Needs Information
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: SERVER 5.3.5
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Server Version: 5.3
      OS Name/Version: CentOS 7.4

      Puppet status endpoint returns HTTP 404, even though returned json says it's is_alive.

      $:~ chic_cat$ curl -I -k https://puppet:8140/puppet/v3/status/whatever?environment=production
      HTTP/1.1 404 Not Found
      Date: Sat, 01 Sep 2018 04:13:24 GMT
      Cache-Control: must-revalidate,no-cache,no-store
      Content-Type: text/html;charset=iso-8859-1
      Content-Length: 340
      Server: Jetty(9.4.z-SNAPSHOT)

      $:~ chic_cat$ curl -k https://puppet:8140/puppet/v3/status/whatever?environment=production

      {"is_alive":true,"version":"5.5.0"}

      $:~ chic_cat$

      Desired Behavior:

       

      200 OK

       

       

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                chic_cat Konstantin
                Reporter:
                chic_cat Konstantin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: