Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 6.y
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
    • Team:
      Server
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 5 or 6
      Puppet Server Version: 5.x or 6.x
      OS Name/Version: N/A

      Desired Behavior:

      Latest Puppet Server 5.x or 6.x release uses JRuby 9.2, which is Ruby 2.5.  This also matches the Ruby that ships with Puppet and will be a supported version for quite a while.

      Current Behavior:

      Puppet Server 5.x or 6.x uses JRuby 9.1, which is Ruby 2.3.  Ruby 2.3 is EOL in March of 2019. 

      I presume there are already plans for a minor point release around that time to bump the jruby version but opening this just in case

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sbrimhall-sfdc Scott Brimhall
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support