Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2542

Puppetserver consumes 100% CPU

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: SERVER 5.3.8
    • Fix Version/s: None
    • Component/s: Performance, Puppet Server
    • Labels:
      None
    • Environment:
    • Template:
      PUP Bug Template
    • Team:
      Froyo
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 5.5.14
      Puppet Server Version: 5.3.8
      OS Name/Version: OEL 7.4

      On some occasions in the week, the puppetserver jumps to 100% cpu and generates a lot of load. The logfile has no errors on this time. strace shows a lot of sched_yield. Requests are being processed, but slowly.

      We cannot reproduce, because we do not know what is causing it. We have like 50module from git/forge in our Puppetfile and deploying via webhook with r10k.

      When we restart, everything seems to be fine again. Until next time....
       
      has anybody the same problems or know how to get this behavior to stop? 

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            rwaffen Robert Waffen
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support