Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2654

Upgrade puppetserver#master to newest FIPS libraries/testing

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: SERVER 6.7.1
    • Component/s: None
    • Template:
    • Team:
      Froyo
    • Release Notes:
      Known Issue
    • Release Notes Summary:
      Puppet Server may no longer be configured to accept SSLv3 traffic
    • QA Risk Assessment:
      Needs Assessment

      Description

      While iterating on FIPS testing changes in jvm-ssl-utils, clj-http-client, and tk-ws-jetty9 were required. We need to take these improvements up. Our original FIPS testing was lacking enforcement of a security policy. We need to be including this in FIPS testing as well.

        Attachments

          Activity

            People

            Assignee:
            justin Justin Stoller
            Reporter:
            justin Justin Stoller
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support