Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2846

specify new version of file_content api

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:
    • Team:
      Froyo
    • QA Risk Assessment:
      Needs Assessment

      Description

      Specify the API to be used in SERVER-2845. For now it only needs to serve file content out of bolt projects but it might be good to make it flexible enough to also serve from environments in the future and replace the existing file_content endpoint (so essentially a v4).

      In scope:

      • API spec to serve file_content from bolt projects
      • Source is addressed as project name and version
      • Allow specifying either the project or environment as a source

      Out of scope:

      • implementing serving from environment

      Open questions:

      • Is this actually necessary? Even though this will have a new backend implementation it's possible it could be slotted into the existing api with a query parameter. Worth double checking.

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              patrick Patrick Carlisle
              Reporter:
              patrick Patrick Carlisle
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support