Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2862

puppetserver crashes on RHEL8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
    • Environment:

      OS: Red Hat Enterprise Linux release 8.2 

      puppetserver-6.12.1-1.el8.noarch

      java-1.8.0-openjdk-headless-1.8.0.262.b10-0.el8_2.x86_64

       

    • Template:
      PUP Bug Template
    • Team:
      Froyo
    • Method Found:
      Needs Assessment
    • Zendesk Ticket IDs:
      46162
    • Zendesk Ticket Count:
      1
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 6.10.0
      Puppet Server Version: 6.12.1, 6.7.0
      OS Name/Version: RHEL8

      I have a RHEL7 box running puppetserver 6.7 without problems. Trying to install a new puppetserver on RHEL8 results in repeated java crashes when put under load. RHEL7 and RHEL8 boxes are configured identically and reads the same puppet code.

      I have tested puppetserver 6.7 and the latest, 6.12.1, and tried both java-1.8.0-openjdk and java-11-openjdk. Running with light loads seems to work, but put under some stress (which the RHEL7 box manages fine) the java crashes with errors like these:

       

      puppetserver[54280]: # A fatal error has been detected by the Java Runtime Environment:
      puppetserver[54280]: # SIGSEGV (0xb) at pc=0x00007fcc8fef3c3e, pid=54287, tid=0x00007fcbd1ee6700
      puppetserver[54280]: # JRE version: OpenJDK Runtime Environment (8.0_262-b10) (build 1.8.0_262-b10)
      puppetserver[54280]: # Java VM: OpenJDK 64-Bit Server VM (25.262-b10 mixed mode linux-amd64 compressed oops)
      puppetserver[54280]: # Problematic frame:
      puppetserver[54280]: # C [libc.so.6+0x15dc3e] __memmove_avx_unaligned_erms+0x9e

      puppetserver[55962]: # A fatal error has been detected by the Java Runtime Environment:
      puppetserver[55962]: # SIGSEGV (0xb) at pc=0x00007f10879c7fe4, pid=55969, tid=0x00007f0ed1bb9700 
      puppetserver[55962]: # JRE version: OpenJDK Runtime Environment (8.0_262-b10) (build 1.8.0_262-b10)
      puppetserver[55962]: # Java VM: OpenJDK 64-Bit Server VM (25.262-b10 mixed mode linux-amd64 compressed oops)
      puppetserver[55962]: # Problematic frame:
      puppetserver[55962]: # C [libcrypt.so.1+0x2fe4]

       

      puppetserver[750529]: [thread 140566186202880 also had an error][thread 140566179886848 also had an error]
      # A fatal error has been detected by the Java Runtime Environment:
      puppetserver[750529]: #
      puppetserver[750529]: # SIGSEGV (0xb) at pc=0x00007fd953a83550, pid=750536, tid=0x00007fd916ef2700
      puppetserver[750529]: #
      puppetserver[750529]: [thread 140566428763904 also had an error]# JRE version: OpenJDK Runtime Environment
      0)
      puppetserver[750529]: # Java VM: OpenJDK 64-Bit Server VM (25.262-b10 mixed mode linux-amd64 compressed oo
      puppetserver[750529]: # Problematic frame:
      puppetserver[750529]: # C 0x00007fd953a83550
      puppetserver[750529]: #
      puppetserver[750529]: # Core dump written. Default location: //core or core.750536
      puppetserver[750529]: #
      puppetserver[750529]: # An error report file with more information is saved as:
      puppetserver[750529]: # /tmp/hs_err_pid750536.log
      puppetserver[750529]: [thread 140566443476736 also had an error]
      puppetserver[750529]: [thread 140571393914624 also had an error]
      puppetserver[750529]: [thread 140570362042112 also had an error]
      puppetserver[750529]: [thread 140570357831424 also had an error]
      puppetserver[750529]: =============== DEBUG MESSAGE: illegal bytecode sequence - method not verified ================
      puppetserver[750529]: [thread 140566325888768 also had an error]
      puppetserver[750529]: [thread 140573830289152 also had an error]
      puppetserver[750529]: [thread 140566545291008 also had an error]
      

       

       

       

      There is no clue to what triggers the crash in the logs, even with debug enabled. Any idea what could be causing this?

      Attaching an error report from java if that could help.

       

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            wiad Adam Winberg
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support