Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-2922

puppetserver-7.0.0 redhat7 rpm requires java-1.8.0-openjdk-headless

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Do
    • Affects Version/s: SERVER 7.0.0
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
      None
    • Environment:

      Redhat 7.9 x86_64

    • Template:
      PUP Bug Template
    • Team:
      Release Engineering
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 7.0.0
      Puppet Server Version: 7.0.0
      OS Name/Version: Redhat 7.9

      the new puppetserver-7.0.0 redhat packages still "require" java-1.8.0-openjdk-headless, even though the package supports OpenJDK 11.

      Desired Behavior: puppetserver-7.0.0 should probably switch to just requiring `/usr/bin/java` since redhat's 1.8.0 and 11 openjdk packages do not have a common provides like `jre-headless`

      Actual Behavior:

      [root@puppet modules]# yum install puppetserver -y
      Resolving Dependencies
      --> Running transaction check
      ---> Package puppetserver.noarch 0:7.0.0-1.el7 will be installed
      --> Processing Dependency: java-1.8.0-openjdk-headless for package: puppetdb-7.0.0-1.el7.noarch
      --> Running transaction check
      ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.272.b10-1.el7_9 will be installed
      --> Finished Dependency Resolution

      Dependencies Resolved

      ===========================================================================================
      Package Arch Version Repository Size
      ===========================================================================================
      Installing:
      puppetserver noarch 7.0.0-1.el7 puppet7 61 M
      Installing for dependencies:
      java-1.8.0-openjdk-headless x86_64 1:1.8.0.272.b10-1.el7_9 rhel7-server-rpms 33 M

      Transaction Summary
      ===========================================================================================
      Install 1 Package (+1 Dependent package)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ruckc Curtis Ruck
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support