Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-455

Fix ruby spec failure on version bump

    Details

      Description

      Trying to update our dependency on puppet-agent to 4.0.0-rc1, we're now seeing this failure in the Ruby spec tests:

      Failures:
       
        1) Puppet::Server::Master puppet version returns the correct puppet version number
           Failure/Error: master.puppetVersion.should == '3.7.4'
             expected: "3.7.4"
                  got: "4.0.0-rc1" (using ==)
           # ./spec/puppet-server-lib/puppet/jvm/master_spec.rb:17:in `(root)'
           # ./spec/run_specs.rb:5:in `(root)'
           # form-init111985068497148575.clj:1:in `invoke'
           # main.clj:274:in `invoke'
           # main.clj:279:in `invoke'
           # main.clj:307:in `invoke'
           # main.clj:342:in `invoke'
           # main.clj:420:in `doInvoke'
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jeff Jeff McCune
                Reporter:
                jeff Jeff McCune
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support