Uploaded image for project: 'Puppet Server'
  1. Puppet Server
  2. SERVER-540

puppetserver 1.0.8-1puppetlabs1 no longer honours proxy for installing gems

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: SERVER 1.0.8
    • Fix Version/s: None
    • Component/s: Puppet Server
    • Labels:
      None
    • Template:

      Description

      When using puppet server 1.0.8, I can no longer install gems via our proxy server:

      puppetserver gem install hiera-eyaml -v 1.1.4
      ERROR: Could not find a valid gem 'hiera-eyaml' (= 1.1.4), here is why:
      Unable to download data from https://rubygems.org/ - Errno::ECONNREFUSED: Connection refused - Connection refused (https://rubygems.org/specs.4.8.gz)

      Downgrading to 1.0.2-1puppetlabs1 resolved this issue for me:
      puppetserver gem install hiera-eyaml -v 1.1.4
      Fetching: trollop-2.1.2.gem (100%)
      Successfully installed trollop-2.1.2
      Fetching: highline-1.7.1.gem (100%)
      Successfully installed highline-1.7.1
      Fetching: hiera-eyaml-1.1.4.gem (100%)
      Successfully installed hiera-eyaml-1.1.4
      3 gems installed

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  mkrakowitzer Merritt
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: