Uploaded image for project: 'Trapperkeeper'
  1. Trapperkeeper
  2. TK-369

Consider upgrading tk-jetty9 dependency to Jetty 9.4.x

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: TK Puppet5.0
    • Component/s: None
    • Labels:
    • Template:
    • Epic Link:
    • Team:
      Enterprise in the Cloud
    • Sub-team:
    • Story Points:
      5
    • Sprint:
      WC 2017-03-08
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      Jetty 9.4 update will be called out in the puppetserver 5 release notes.

      Description

      The Jetty team is intending to EOL Jetty 9.2 in the May 2016 timeframe. The latest tk-jetty9, 1.5.6, is still using Jetty 9.2.10. We should consider upgrading to something in the Jetty 9.3.x series in order to stay on a version that is "supported" by the Jetty team.

      Past Haus indicated that he knows of at least one issue that we're likely to face in porting tk-jetty9 to the Jetty 9.3.x series - some change related to moving / removing one of the Gzip-related classes. We should watch out for that when we do the port.

      One issue which may block us moving to Jetty 9.3.x soon, though, is that it has a minimum requirement of JDK version 8.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                matthaus Past Haus
                Reporter:
                jeremy.barlow Jeremy Barlow
              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support