[CPR-378] puppetlabs-release now requires redhat-release but doesn't exist on centos Created: 2016/09/08  Updated: 2017/12/28  Resolved: 2017/12/28

Status: Closed
Project: Community Package Repository
Component/s: Packaging
Affects Version/s: None
Fix Version/s: 2017/08/02

Type: Bug Priority: Blocker
Reporter: Emilien Macchi Assignee: Melissa Stone
Resolution: Done Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

centos7


Template:

Error rendering 'issue-templates-customfield'. Please contact your Jira administrators.

Story Points: 1
Sprint: RE 2016-09-21

 Description   

wget http://yum.puppetlabs.com/puppetlabs-release-el-7.noarch.rpm -O /tmp/puppet.rpm
sudo -E rpm -ivh /tmp/puppet.rpm
error: Failed dependencies:
redhat-release >= 22.0 is needed by puppetlabs-release-22.0-1.noarch

the minimum version that is required is wrong, redhat-release 22.0 doesn't exist.



 Comments   
Comment by Emilien Macchi [ 2016/09/08 ]

bkero is trying to fix it here: https://github.com/puppetlabs/puppetlabs-release/pull/72

Comment by Emilien Macchi [ 2016/09/08 ]

it also overlaps with https://github.com/puppetlabs/puppetlabs-release/pull/71

Comment by Melissa Stone [ 2016/09/08 ]

New packages are up and available. Thank you everyone for your patience.

Generated at Sat Aug 08 17:49:57 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.