[ENTERPRISE-1183] Console classification regex behaving differently on PE version 2018.1.x Created: 2018/06/17  Updated: 2019/04/25  Resolved: 2019/04/25

Status: Resolved
Project: Puppet Enterprise
Component/s: Puppet Server, PuppetDB
Affects Version/s: PE 2018.1.0
Fix Version/s: PE 2018.1.3

Type: Bug Priority: Major
Reporter: Karthikeyan Kanagaraj Assignee: Unassigned
Resolution: Fixed Votes: 1
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: File Regex issue 2018.1.mov    
Issue Links:
Relates
relates to PDB-3930 PQL's ~ matches incorrectly on dotted... Closed
Template:
Console Browser: Chrome
Acceptance Criteria:

2018.1.x also has to accept the filter and list applicable nodes 

Method Found: Needs Assessment
CS Priority: Reviewed
CS Impact: This tracks back to an issue in PDB-3930. Will log CS Triage feedback there.
QA Risk Assessment: Needs Assessment

 Description   

Hi,

Node classification regex is behaving differently on latest version PEs (2018.1.0 and 2018.1.2).

"rule": [  "and", [ "~", [ "fact", "hostname" ], "^pe-" ] ],  

When I tried to add new nodes using above rule on 2016.4.11, 2017.3.2  and 2017.3.5, I can see nodes got filtered and listed on the console. 

When I tried to use same rule on version 2018.1.0 and 2018.1.2, showing listed nodes as "0". 

When I try symbol ^ only , this is listing all nodes, when I try to add character after the symbol* ^ *it's not listing. 

I have attached my test case with this ticket for reference. 

 



 Comments   
Comment by Yasmin Rajabi [ 2018/07/17 ]

This will be fixed in 2018.1.3

Generated at Sat Sep 19 12:38:47 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.