[MODULES-8263] puppet_agent : bump module dependency versions Created: 2018/11/19  Updated: 2019/01/08  Resolved: 2019/01/07

Status: Closed
Project: Modules
Component/s: puppet_agent
Affects Version/s: None
Fix Version/s: None

Type: New Feature Priority: Normal
Reporter: Francesco Duranti Assignee: Casey Williams
Resolution: Duplicate Votes: 0
Labels: community, dependencies
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Duplicate
duplicates MODULES-8317 Update puppetlabs-puppet_agent module... Resolved
Template: MODULES Bug Template
Team: Platform OS
QA Risk Assessment: Needs Assessment

 Description   

Basic Info
*Module Version:1.7.0
*Puppet Version:2019.0.1
*OS Name/Version:Centos/Redhat 7

Bump module dependencies versions for puppet_agent module.

Desired Behavior:
Being able to use latest inifile/apt/stdlib modules from forge.
The actual version of puppet_agent have requirement related to really old version of some modules.

Actual Behavior:
version 1.7.0 have those requirement:
puppetlabs-stdlib (>= 4.6.0 < 5.0.0)
puppetlabs-transition (>= 0.1.1 < 0.2.0)
puppetlabs-inifile (>= 1.2.0 <= 2.1.0)
puppetlabs-apt (>= 2.0.1 < 3.0.0)

Some of those modules are not even supported with puppet 2019.0.1 (for example it require stdlib >5.0.0).



 Comments   
Comment by Casey Williams [ 2019/01/07 ]

I'm going to close this as a duplicate of MODULES-8317, changes from which have been merged to the master branch of the module – this updates all of the dependencies so that they support a version of puppet between 4 and 6 (inclusive). We'll be doing a 2.0 release of the module with these changes this month.

Comment by Casey Williams [ 2019/01/07 ]

I will also note for anyone finding this ticket that puppetlabs-transition has been removed as a dependency as part of this work. 

Generated at Sat Dec 07 22:22:03 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.