[PA-1880] Unvendor semantic-puppet Created: 2018/02/28  Updated: 2018/07/30  Due: 2018/05/16  Resolved: 2018/06/25

Status: Closed
Project: Puppet Agent
Component/s: None
Affects Version/s: None
Fix Version/s: puppet-agent 6.0.0

Type: Epic Priority: Critical
Reporter: Josh Cooper Assignee: Jorie Tappa
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
is blocked by PA-1885 Allow hard gem dependencies to be add... Closed
Relates
relates to PA-1077 Figure out how to consolidate gem dep... Accepted
Epic Name: Unvendor SemanticPuppet
Template:
Team/s:
Platform Core
Sub-team: Coremunity
Epic Status: Done
Release Notes: Not Needed
QA Risk Assessment: Needs Assessment

 Description   

Puppet currently vendors an old version of semantic_puppet that doesn't handle rc and git describe based versions correctly. This epic contains tickets across various projects to unvendor semantic_puppet from the puppet repo, updating the semantic_puppet gem in puppet-agent (and if needed puppetserver).



 Comments   
Comment by Josh Cooper [ 2018/06/25 ]

All tickets completed.

Generated at Thu Nov 14 01:04:06 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.