[PA-1941] OpenSSL 1.1.0 for realz Created: 2018/03/21  Updated: 2018/08/08  Resolved: 2018/08/08

Status: Closed
Project: Puppet Agent
Component/s: None
Affects Version/s: None
Fix Version/s: puppet-agent 6.0.0

Type: Task Priority: Normal
Reporter: Sean McDonald Assignee: Sean McDonald
Resolution: Done Votes: 0
Labels: packaging, sadness, ssl
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
is blocked by PA-2135 OpenSSL 1.1.0 builds failing tests on... Closed
is blocked by PA-1942 Build POC agent with openssl 1.1.0 fo... Closed
Relates
relates to PA-2107 Build a pl-perl package Resolved
Template:
Acceptance Criteria:
  • Puppet 6 agents build with vendored openssl 1.1.0

[X] EL variant Linux (aarch failure separately ticketed)
[X] SLES variant Linux
[X] Debian variant Linux
[X] cross-compiled Linux
[X] MacOS
[ ] AIX
[X] Windows
[X] Solaris

Epic Link: OpenSSL 1.1 in puppet-agent
Team: Platform OS
Sprint: Platform OS Kanban
Release Notes: New Feature
Release Notes Summary: We have updated the version of OpenSSL used in puppet-agent to version 1.1.0h.
QA Risk Assessment: Needs Assessment

 Description   

In preparation for the openssl support cycle, we should update to openssl 1.1.0 for puppet 6.0.0.

This will be a major change for the agent, so care will need to be taken to ensure the agent doesn't break the world.



 Comments   
Comment by Sean McDonald [ 2018/08/08 ]

This has passed master integration tests, and we can open any issues related to the OpenSSL update as new tickets. This ticket is done.

Generated at Tue Feb 25 17:31:30 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.