[PDB-1389] PuppetDB won't install alongside the puppet-agent on debian Created: 2015/04/03  Updated: 2015/04/21  Resolved: 2015/04/06

Status: Closed
Project: PuppetDB
Component/s: None
Affects Version/s: PDB 2.3.2
Fix Version/s: PDB 2.3.3

Type: Bug Priority: Normal
Reporter: Past Haus Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: AIO
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Story Points: 2
Sprint: RE 2015-04-08

 Description   

Because of how debian packages work, they cannot have versioned provides. A consequence of this is that despite puppet-agent providing both puppet and puppet-common, because puppetdb requires puppet/puppet-common >= 3.5.1 the puppet-agent package cannot satisfy those dependencies, which renders the combination uninstallable.

apt-get install puppetdb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 puppetdb : Depends: puppet (>= 3.5.1)
E: Unable to correct problems, you have held broken packages.



 Comments   
Comment by Michael Stahnke [ 2015/04/06 ]

Merged at https://github.com/puppetlabs/puppetdb/commit/ee6e9e95fba4179cea087a175d8a0d639f190932

Generated at Thu Feb 27 00:46:55 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.